[单调队列]假期
假 期 假期 假期
题目描述
经过几个月辛勤的工作,FJ决定让奶牛放假。假期可以在1…N天内任意选择一段(需要连续),每一天都有一个享受指数W。但是奶牛的要求非常苛刻,假期不能短于P天,否则奶牛不能得到足够的休息;假期也不能超过Q天,否则奶牛会玩的腻烦。FJ想知道奶牛们能获得的最大享受指数。
输入
第一行:N,P,Q.
第二行:N个数字,中间用一个空格隔开,每个数都在longint范围内。
输出
一个整数,奶牛们能获得的最大享受指数。
样例输入
5 2 4
-9 -4 -3 8 -6
样例输出
5
数据范围
50% 1≤N≤10000
100% 1≤N≤100000
1<=p<=q<=n
提示
选择第3-4天,享受指数为-3+8=5。
code
#include<stdio.h>
#include<iostream>
using namespace std;
int maxx(int a,int b){return a>b?a:b;}
int n,p,q,h=1,t=0,ans=-999999999;
int que[100005],a[100005];
long long te[100005]={0};
int main(){
scanf("%d%d%d",&n,&p,&q);
for(int i=1;i<=n;++i)scanf("%d",&a[i]),te[i]=te[i-1]+a[i];
for(int i=p;i<=n;++i){
while(h<=t and te[que[t]-1]>=te[i-p])--t;
que[++t]=i+1-p;
while(h<=t and que[h]<i+1-q)++h;
ans=maxx(ans,te[i]-te[que[h]-1]);
}
printf("%d",ans);
return 0;
}