HDU-1597 find the nth digit(思维)
原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1597
测试样例
Sample Input
6
1
2
3
4
5
10
Sample Output
1
1
2
1
2
4
解题思路: 我们把每个 s i s_i si看成一组,由于长度呈等差数列增长,故我们可以第 n n n个数字判断是在哪个组中,知道了这个我们对每个组继续进行分析,我们发现是以1~9为一个循环,所以我们只要知道这个第 n n n个数字是在这个组中的哪个位置,则此题自然易解。注意思维,具体看代码。
AC代码
/*
*邮箱:unique_powerhouse@qq.com
*blog:https://me.csdn.net/hzf0701
*注:文章若有任何问题请私信我或评论区留言,谢谢支持。
*
*/
#include<bits/stdc++.h>//POJ不支持
#define rep(i,a,n) for(int i=a;i<=n;i++)
#define per(i,a,n) for(int i=a;i>=n;i--)
using namespace std;
const int inf=0x3f3f3f3f;//无穷大。
const int maxn=1e5;//限定值。
typedef long long ll;
int k,n;
int main(){
while(cin>>k){
while(k--){
cin>>n;
int cnt=1;
while(n>cnt){
n-=cnt;
cnt++;
}
while(n>=10){
n-=9;
}
cout<<n<<endl;
}
}
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· winform 绘制太阳,地球,月球 运作规律
· AI与.NET技术实操系列(五):向量存储与相似性搜索在 .NET 中的实现
· 超详细:普通电脑也行Windows部署deepseek R1训练数据并当服务器共享给他人
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)