HDU 1051 Wooden Sticks (简单贪心)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8280    Accepted Submission(s): 3371


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by
one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing
tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise,
it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9),
(5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an
integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each
of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

 

Output
The output should contain the minimum setup time in minutes, one per line.
 

 

Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

 

Sample Output
2 1 3
 

简单的贪心题目,和导弹防御系统很类似的一道题。只需要按length从小到大排序,然后寻找递增序列的个数即可。

 

View Code
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MN=5050;
struct wooden
{
    int length;
    int weight;
}node[MN],pack[MN/10];
bool cmp(struct wooden a,struct wooden b)
{
    if(a.length!=b.length) return a.length<b.length;
    else return a.weight<b.weight;
}
int main()
{
    int cas,n,i,j;
    scanf("%d",&cas);
    while(cas--){
        scanf("%d",&n);
        for(i=0;i<n;i++){
            scanf("%d%d",&node[i].length,&node[i].weight);
        }
        sort(node,node+n,cmp);
        int b=node[0].weight;
        int flag=0,o=0;
        for(i=1;i<n;i++){
            if(node[i].weight>=b){
                b=node[i].weight;
            }
            else {
                for(j=0;j<o;j++){
                    if(node[i].weight>=pack[j].weight){
                        pack[j].weight=node[i].weight;
                        break;
                    }
                }
                if(j==o) {
                    pack[o++].weight=node[i].weight;
                }
            }
        }
        if(i==n) flag=1;
        printf("%d\n",o+flag);
    }
    return 0;
}

 

 

posted @ 2013-04-09 21:37  ZeroCode_1337  阅读(233)  评论(0编辑  收藏  举报