DreamJudge-1310-奥运排序问题(精华)
1.题目描述
Time Limit: 1000 ms
Memory Limit: 256 mb
按要求,给国家进行排名。
输入输出格式
输入描述:
有多组数据。
第一行给出国家数N,要求排名的国家数M,国家号从0到N-1。
第二行开始的N行给定国家或地区的奥运金牌数,奖牌数,人口数(百万)。
接下来一行给出M个国家号。
输出描述:
排序有4种方式: 金牌总数 奖牌总数 金牌人口比例 奖牌人口比例
对每个国家给出最佳排名排名方式 和 最终排名
格式为: 排名:排名方式
如果有相同的最终排名,则输出排名方式最小的那种排名,对于排名方式,金牌总数 < 奖牌总数 < 金牌人口比例 < 奖牌人口比例
如果有并列排名的情况,即如果出现金牌总数为 100,90,90,80.则排名为1,2,2,4.
每组数据后加一个空行。
输入输出样例
输入样例#:
4 4
4 8 1
6 6 2
4 8 2
2 12 4
0 1 2 3
4 2
8 10 1
8 11 2
8 12 3
8 13 4
0 3
输出样例#:
1:3
1:1
2:1
1:2
1:1
1:1
题目来源
浙江大学机试题
2.题解
2.1
思路
1.这里由于存在多种判断规则,所以巧妙使用函数指针----函数类型(*函数名)(参数列表),增强程序的兼容性!
vector<int> getRankings(const vector<Country> &countries, bool(*compare)(const Country&, const Country&)) {...}
2.在其中根据规则对于国家进行排序,然后如何知道原有顺序国家的依次排名呢?这里我们保存id字段,即使排序后顺序改变,也可以快速定位到原有顺序了。
3.这里要求我们如果有相同的最终排名,则输出排名方式最小的那种排名,对于排名方式,金牌总数 < 奖牌总数 < 金牌人口比例 < 奖牌人口比例
而sort排序对于pair类型比较,首先比较第一个元素,然后比较第二个元素;
也就是在先比较排名(first)后,在比较排名方式先后(second)即可
vector<pair<int, int>> rankings = {
{goldRankings[countryId], 1},
{medalRankings[countryId], 2},
{goldPerCapitaRankings[countryId], 3},
{medalPerCapitaRankings[countryId], 4}
};
sort(rankings.begin(), rankings.end()); // 对于pair类型比较,首先比较第一个元素,然后比较第二个元素
代码
#include <bits/stdc++.h>
using namespace std;
struct Country {
int id;
int gold;
int medal;
int population;
};
bool compareByGold(const Country &a, const Country &b) {
return a.gold > b.gold;
}
bool compareByMedal(const Country &a, const Country &b) {
return a.medal > b.medal;
}
bool compareByGoldPerCapita(const Country &a, const Country &b) {
// return static_cast<double>(a.gold) / a.population > static_cast<double>(b.gold) / b.population;
return a.gold * b.population > b.gold * a.population;
}
bool compareByMedalPerCapita(const Country &a, const Country &b) {
// return static_cast<double>(a.medal) / a.population > static_cast<double>(b.medal) / b.population;
return a.medal * b.population > b.medal * a.population;
}
vector<int> getRankings(const vector<Country> &countries, bool(*compare)(const Country&, const Country&)) {
vector<Country> sortedCountries = countries;
// 根据具体规则对国家进行排序,虽然打乱了国家顺序,但通过id字段依旧可以快速定位!
sort(sortedCountries.begin(), sortedCountries.end(), compare);
// 生成相应排名(从rank=1开始,如果排名相同,继承上一个rank; 否则采用最新的rank(rank++))
vector<int> rankings(countries.size());
int rank = 1;
for (int i = 0; i < sortedCountries.size(); ++i) {
// 这里巧妙调用函数指针进行排名判等(如果前<=后 && 后<=前 ,那么必然是 前 == 后)
if (i > 0 && !compare(sortedCountries[i - 1], sortedCountries[i]) && !compare(sortedCountries[i], sortedCountries[i - 1])) {
rankings[sortedCountries[i].id] = rankings[sortedCountries[i - 1].id];
} else {
rankings[sortedCountries[i].id] = rank;
}
rank++;
}
return rankings;
}
int main() {
int N, M;
while (cin >> N >> M) {
vector<Country> countries(N);
for (int i = 0; i < N; ++i) {
countries[i].id = i;
cin >> countries[i].gold >> countries[i].medal >> countries[i].population;
}
vector<int> countryIds(M);
for (int i = 0; i < M; ++i) {
cin >> countryIds[i];
}
// 更新各种规则下的相应排名信息
vector<int> goldRankings = getRankings(countries, compareByGold);
vector<int> medalRankings = getRankings(countries, compareByMedal);
vector<int> goldPerCapitaRankings = getRankings(countries, compareByGoldPerCapita);
vector<int> medalPerCapitaRankings = getRankings(countries, compareByMedalPerCapita);
for (int countryId : countryIds) {
vector<pair<int, int>> rankings = {
{goldRankings[countryId], 1},
{medalRankings[countryId], 2},
{goldPerCapitaRankings[countryId], 3},
{medalPerCapitaRankings[countryId], 4}
};
sort(rankings.begin(), rankings.end()); // 对于pair类型比较,首先比较第一个元素,然后比较第二个元素
cout << rankings[0].first << ":" << rankings[0].second << endl;
}
cout << endl;
}
return 0;
}