浙大PAT刷题-1004.成绩排名

1.题目

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

2.题解

2.1 STL容器的使用

思路

主要的麻烦点在于要同时存储名字和学号两个字段,所以这里使用pair配合vector进行存储

代码

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n;
    cin >> n;
    pair<vector<string>, int> maxScore(vector<string>(2), 0);
    pair<vector<string>, int> minScore(vector<string>(2), 100);
    for(int i = 0; i < n; i++){
        string name, idx;
        int score;
        cin >> name >> idx >> score;
        if(score > maxScore.second){
            maxScore.first = vector<string>{name, idx};
            maxScore.second = score;
        }

        if(score < minScore.second){
            minScore.first = vector<string>{name, idx};
            minScore.second = score;
        }
    }
    cout << maxScore.first[0] << " " << maxScore.first[1] << endl;
    cout << minScore.first[0] << " " << minScore.first[1] << endl;
}

## 2.2 类的使用
### 思路
这里体验使用类Student来解决问题,完美解决了如何同时存储name和idx的问题。
### 代码

include<bits/stdc++.h>

using namespace std;
class Student{
public:
Student(string name, string idx, int score):name(name),idx(idx),score(score){}
bool operator>(const Student& other)const{
return this->score > other.score;
}

string name;
string idx;
int score;

};
int main(){
int n;
cin >> n;
Student maxStudent("","",-1);
Student minStudent("", "", 101);
for(int i = 0; i < n; i++){
string name, idx;
int score;
cin >> name >> idx >> score;
Student newStudent(name, idx, score);
if(newStudent > maxStudent){
maxStudent = newStudent;
}

    if(minStudent > newStudent){
        minStudent = newStudent;
    }
}
cout << maxStudent.name << " " << maxStudent.idx << endl;
cout << minStudent.name << " " << minStudent.idx << endl;

}

posted @ 2024-05-24 01:46  DawnTraveler  阅读(16)  评论(0编辑  收藏  举报