P1093 [NOIP2007 普及组] 奖学金

1.题目介绍

[NOIP2007 普及组] 奖学金

题目背景

NOIP2007 普及组 T1

题目描述

某小学最近得到了一笔赞助,打算拿出其中一部分为学习成绩优秀的前 \(5\) 名学生发奖学金。期末,每个学生都有 \(3\) 门课的成绩:语文、数学、英语。先按总分从高到低排序,如果两个同学总分相同,再按语文成绩从高到低排序,如果两个同学总分和语文成绩都相同,那么规定学号小的同学排在前面,这样,每个学生的排序是唯一确定的。

任务:先根据输入的 \(3\) 门课的成绩计算总分,然后按上述规则排序,最后按排名顺序输出前五名名学生的学号和总分。

注意,在前 \(5\) 名同学中,每个人的奖学金都不相同,因此,你必须严格按上述规则排序。例如,在某个正确答案中,如果前两行的输出数据(每行输出两个数:学号、总分) 是:

7 279  
5 279

这两行数据的含义是:总分最高的两个同学的学号依次是 \(7\) 号、\(5\) 号。这两名同学的总分都是 \(279\) (总分等于输入的语文、数学、英语三科成绩之和) ,但学号为 \(7\) 的学生语文成绩更高一些。

如果你的前两名的输出数据是:

5 279  
7 279

则按输出错误处理,不能得分。

输入格式

\(n+1\) 行。

\(1\) 行为一个正整数 \(n \le 300\),表示该校参加评选的学生人数。

\(2\)\(n+1\) 行,每行有 \(3\) 个用空格隔开的数字,每个数字都在 \(0\)\(100\) 之间。第 \(j\) 行的 \(3\) 个数字依次表示学号为 \(j-1\) 的学生的语文、数学、英语的成绩。每个学生的学号按照输入顺序编号为 \(1\sim n\)(恰好是输入数据的行号减 \(1\))。

保证所给的数据都是正确的,不必检验。

输出格式

\(5\) 行,每行是两个用空格隔开的正整数,依次表示前 \(5\) 名学生的学号和总分。

样例 #1

样例输入 #1

6
90 67 80
87 66 91
78 89 91
88 99 77
67 89 64
78 89 98

样例输出 #1

6 265
4 264
3 258
2 244
1 237

样例 #2

样例输入 #2

8
80 89 89
88 98 78
90 67 80
87 66 91
78 89 91
88 99 77
67 89 64
78 89 98

样例输出 #2

8 265
2 264
6 264
1 258
5 258

2.题解

2.1 struct结构体+sort排序

思路

这里我们重写一下sort中的比较函数cmp即可
但是要注意学号小的反而大,这里必须要注意不等号方向!!!

代码

#include <bits/stdc++.h>
using namespace std;
struct Student{
	int totalScore;
	int chineseScore;
	int id;
}; 
bool cmp(Student a, Student b){
	if(a.totalScore != b.totalScore) return a.totalScore > b.totalScore;
	if(a.chineseScore != b.chineseScore) return a.chineseScore > b.chineseScore;
	return a.id < b.id;
}
int main(){
	int n;
	cin >> n;
	vector<Student> stu(n);
	for(int i = 0; i < n; i++){
		int chinese, math, english;
		cin >> chinese >> math >> english;
		stu[i].chineseScore = chinese;
		stu[i].totalScore = chinese + math + english;
		stu[i].id = i + 1;
	}
	sort(stu.begin(), stu.end(), cmp);
	for(int i = 0; i < 5; i++){
		cout << stu[i].id << ' ' << stu[i].totalScore << endl;
	}
}

2.2 选择排序

思路

将sort排序部分改为选择排序即可

代码

#include <bits/stdc++.h>
using namespace std;
struct Student{
	int totalScore;
	int chineseScore;
	int id;
}; 
bool cmp(Student a, Student b){
	if(a.totalScore != b.totalScore) return a.totalScore > b.totalScore;
	if(a.chineseScore != b.chineseScore) return a.chineseScore > b.chineseScore;
	return a.id < b.id;
}
int main(){
	int n;
	cin >> n;
	vector<Student> stu(n);
	// 输入 
	for(int i = 0; i < n; i++){
		int chinese, math, english;
		cin >> chinese >> math >> english;
		stu[i].chineseScore = chinese;
		stu[i].totalScore = chinese + math + english;
		stu[i].id = i + 1;
	}
	// 选择排序
	vector<Student> ans(5);
	for(int i = 0; i < 5; i++){
		for(int j = i + 1; j < n; j++){
			if(cmp(stu[j], stu[i]) > 0) swap(stu[i], stu[j]);
		}
	} 
	// 输出 
	for(int i = 0; i < 5; i++){
		cout << stu[i].id << ' ' << stu[i].totalScore << endl;
	}
}

2.3 插入排序

思路

这里由于是要最大的5个,就不是从小到大排序了,所以是从头开始检查更大的。

代码

#include <bits/stdc++.h>
using namespace std;
struct Student{
	int totalScore = 0;
	int chineseScore = 0;
	int id = 300;
}; 
bool cmp(Student a, Student b){
	if(a.totalScore != b.totalScore) return a.totalScore > b.totalScore;
	if(a.chineseScore != b.chineseScore) return a.chineseScore > b.chineseScore;
	return a.id < b.id;
}
int main(){
	int n;
	cin >> n;
	vector<Student> stu(n);
	// 输入 
	for(int i = 0; i < n; i++){
		int chinese, math, english;
		cin >> chinese >> math >> english;
		stu[i].chineseScore = chinese;
		stu[i].totalScore = chinese + math + english;
		stu[i].id = i + 1;
	}
	
	// 插入排序
	vector<Student> ans(5);
	for(int i = 0; i < n; i++){
		for(int j = 0; j < 5; j++){
			if(cmp(stu[i], ans[j]) > 0){
				for(int k = 4; k >= j; k--){
					ans[k] = ans[k-1]; 
				}
				ans[j] = stu[i];
				break;	
			}	
		}
	}
	// 输出 
	for(int i = 0; i < 5; i++){
		cout << ans[i].id << ' ' << ans[i].totalScore << endl;
	}
}
posted @ 2024-02-14 13:40  DawnTraveler  阅读(334)  评论(0编辑  收藏  举报