ZOJ 3551 Bloodsucker (概率DP)

ZOJ Problem Set - 3551
Bloodsucker

Time Limit: 2 Seconds      Memory Limit: 65536 KB

In 0th day, there are n-1 people and 1 bloodsucker. Every day, two and only two of them meet. Nothing will happen if they are of the same species, that is, a people meets a people or a bloodsucker meets a bloodsucker. Otherwise, people may be transformed into bloodsucker with probability p. Sooner or later(D days), all people will be turned into bloodsucker. Calculate the mathematical expectation of D.

Input

The number of test cases (TT ≤ 100) is given in the first line of the input. Each case consists of an integer n and a float number p (1 ≤ n < 100000, 0 < p ≤ 1, accurate to 3 digits after decimal point), separated by spaces.

Output

For each case, you should output the expectation(3 digits after the decimal point) in a single line.

Sample Input

1
2 1

Sample Output

1.000


Author: WU, Yingxin
Contest: ZOJ Monthly, October 2011




 

题目大意:

有 n-1 个人 和 1 个吸血鬼,然后每天有且只有会有两个相遇(可能是人和人,吸血鬼和吸血鬼,人和吸血鬼),当人和吸血鬼相遇时,被感染为吸血鬼的概率为p,问你全部变为吸血鬼的天数的数学期望。


解题思路:

用DP[i]记录还有i个人的时候,全部变为所需要的天数的期望,则:
令 px 表示  C(i,1)*C(n-i,1)/C(n,2)*p  , 也就是 选出1个吸血鬼1个人并且并传染的概率
则: DP[n-i]= 1  + px*DP[n-i-1] + ( 1- px ) *DP[n-i];
化简得到:DP[n-i]= 1.0/px + DP[n-i-1];
即: DP[n-i] = (n-1)*n*p / ( 2.0*i*(n-i) ) + DP[n-i-1];


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

typedef long long ll;

ll C(ll n,ll c){
    if(c>n) return 0;
    else if(c==n) return 1;
    else{
        ll ans=1;
        for(ll i=0;i<c;i++) ans*=(n-i);
        for(ll i=1;i<=c;i++) ans/=i;
        return ans;
    }
}

void solve(){
    ll n;
    double ans=0.0,p;
    scanf("%lld%lf",&n,&p);
    for(ll i=n-1;i>=1;i--){
        ans = 1.0*(n-1)*n / ( 2.0*i*(n-i)*p ) + ans;
    }
    printf("%.3lf\n",ans);
}

int main(){
    int t;
    scanf("%d",&t);
    while(t-- >0){
        solve();
    }
    return 0;
}


posted @ 2014-07-04 14:50  炒饭君  阅读(183)  评论(0编辑  收藏  举报