POJ 2355 Find a multiple(组合数学-抽屉原理)

Find a multiple
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5881   Accepted: 2560   Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source



题目大意:

有n个数,找出一个方案满足:从中选出任意多的数字使得它们的和对n求余为0


解题思路:

用sum[i]记录前 i 项的和。

(1)如果存在某个sum[i]%n==0 ,那么就已经找到了,就是前i项。

(2)如果不存在,则sum[i]%n的取值范围为1~n-1 那么n项sum必然有 sum[i]%n==sum[j]%n,这时候(sum[j]-sum[i])%n=0,也就是 第i+1项到第j项的和对n求余为0,也满足条件了。


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn=11000;
int n,a[maxn],sum[maxn],visited[maxn];

void solve(){
    for(int i=1;i<=n;i++){
        if(sum[i]%n==0){
            printf("%d\n",i);
            for(int t=1;t<=i;t++){
                printf("%d\n",a[t]);
            }
            return ;
        }
    }
    for(int i=0;i<=n;i++) visited[i]=-1;
    for(int i=1;i<=n;i++){
        if(visited[sum[i]%n]!=-1){
            int t=visited[sum[i]%n];
            printf("%d\n",i-t);
            for(t=t+1;t<=i;t++){
                printf("%d\n",a[t]);
            }
        }else{
            visited[sum[i]%n]=i;
        }
    }
}

int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        sum[0]=0;
        for(int i=1;i<=n;i++) sum[i]=sum[i-1]+a[i];
        solve();
    }
    return 0;
}



posted @ 2014-07-29 12:25  炒饭君  阅读(188)  评论(0编辑  收藏  举报