POJ 3461 Oulipo (KMP算法)

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21682   Accepted: 8648

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source


题目大意:

T组测试数据,每组两行分别为word和text,问你text中包含多少个word子串。

解题思路:

较裸的一题KMP算法,关于KMP算法,参照:http://www.cppblog.com/oosky/archive/2006/07/06/9486.html

解题代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <string>
using namespace std;

const int maxn=11000;
int next[maxn];

char word[maxn],text[maxn*100];

void kmp(){
    int n=strlen(word);
    for(int i=0;i<=n;i++) next[i]=0;
    for(int i=1;i<n;i++){
        int j=i;
        while(j>0){
            j=next[j];
            if(word[j]==word[i]){
                next[i+1]=j+1;
                break;
            }
        }
    }
    int m=strlen(text),ret=0;
    for(int i=0,j=0;i<m;i++){
        if( j<n && text[i]==word[j]){
            j++;
        }else{
            while(j>0){
                j=next[j];
                if(text[i]==word[j]){
                    j++;
                    break;
                }
            }
        }
        if(j==n){
            ret++;
        }
    }
    printf("%d\n",ret);
}

int main(){
    int t;
    scanf("%d\n",&t);
    while(t-- >0){
        scanf("%s%s",word,text);
        kmp();
    }
    return 0;
}




posted @ 2014-06-03 18:36  炒饭君  阅读(134)  评论(0编辑  收藏  举报