uva 11368 Nested Dolls



  G: Nested Dolls 

Dilworth is the world's most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2 . Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?

\epsfbox{p11368.eps}

Input 

On the first line of input is a single positive integer 1$ \le$t$ \le$20 specifying the number of test cases to follow. Each test case begins with a positive integer 1$ \le$m$ \le$20000 on a line of itself telling the number of dolls in the test case. Next follow2m positive integers w1h1w2h2,..., wmhm , where wi is the width and hi is the height of doll number i1$ \le$wihi$ \le$10000 for all i .

Output 

For each test case there should be one line of output containing the minimum number of nested dolls possible.

Sample Input 

4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51

Sample Output 

1
2
3
2




题目大意:T组测试数据,每组数据,n个套娃,2*n 个数据表示 套娃的宽和高,依次为W1,H1,W2,H2...................Wn,Hn,只有 wi<wj 并且 hi<hj 的时候 i 号套娃能套进 j 号套娃,问你露在外面的套娃最左多少个

解题思路:按照套娃的宽度从大到小排序,套娃的高度从小到大排序,利用贪心的思想,从左往右扫一遍,每个套娃尽量选择刚好高于他的套娃,如果没有,自己额外算一套


#include <iostream>
#include <cstdio>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;

struct toy{
    int w,h;
    friend bool operator < (toy a,toy b){
        if(a.w!=b.w) return a.w>b.w;
        else return a.h<b.h;
    }
};

vector <toy> v;
int n;

void input(){
    scanf("%d",&n);
    v.resize(n);
    for(int i=0;i<n;i++){
        scanf("%d%d",&v[i].w,&v[i].h);
    }
}

void computing(){
    sort(v.begin(),v.end());
    multiset <int> mys;
    multiset <int>::iterator it;
    mys.insert(10000000);
    for(int i=0;i<v.size();i++){
        it=mys.upper_bound(v[i].h);
        if(it!=mys.end()){
            mys.erase(it);
            mys.insert(v[i].h);
        }else{
            mys.insert(v[i].h);
        }
    }
    cout<<mys.size()<<endl;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t-- >0){
        input();
        computing();
    }
    return 0;
}



posted @ 2014-03-25 13:44  炒饭君  阅读(333)  评论(0编辑  收藏  举报