POJ 1995 Raising Modulo Numbers (数论-整数快速幂)

Raising Modulo Numbers
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 4379   Accepted: 2516

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

Source


题目大意:

T组测试数据,求(A1B1+A2B2+ ... +AHBH)mod M.


解题思路:

对于普通暴力算法一定是 

A1*A1*A1.....*A1 乘以 B1次,

A2*A2...........*A2  乘以 B2次,

......................................

然后全部相加起来,这样效率很低,肯定是超时了


那么有什么办法解决这一问题,可以用快速幂,

如果 A1^2有了,那么 A1^4就可以得到,A1^8也可以得到,...... ,立刻由n降到了lgn

可以用位运算来模拟。


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

typedef long long ll;

ll a,b,mod;

void solve(){
    ll ans=0;
    int m;
    scanf("%d",&m);
    while(m-- >0){
        scanf("%lld%lld",&a,&b);
        ll sum=1;
        while(b>0){
            if(b&1) sum=(sum*a)%mod;
            a=(a*a)%mod;
            b/=2;
        }
        ans=(ans+sum)%mod;
    }
    cout<<ans<<endl;
}

int main(){
    int t;
    cin>>t;
    while(t-- >0){
        scanf("%lld",&mod);
        solve();
    }
    return 0;
}





posted @ 2014-06-18 21:51  炒饭君  阅读(151)  评论(0编辑  收藏  举报