1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a tree, and M (<), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

DFS:因为要知道有多少层,每次进DFS先更新一下最大层数
#include <bits/stdc++.h>
using namespace std;
int n,k,id,m,k2;
vector<int> v[100010];
int num[100010];
int maxn = 0;
void find(int a,int b)
{
    maxn = max(maxn,b);
    if(v[a].size() == 0){
        num[b] += 1;
        return ;
    }
    else{
        for(int i=0;i<v[a].size();i++){
            find(v[a][i],b+1);
        }
    }
}
int main()
{
    scanf("%d %d",&n,&m);
    memset(num,0,sizeof(num));
    for(int i=1;i<=m;i++)
    {
        scanf("%d",&id);
        scanf("%d",&k);
        for(int j=0;j<k;j++)
        {
            scanf("%d",&k2);
            v[id].push_back(k2);
        }
    }
    find(1,1);
    for(int i=1;i<=maxn;i++)
    {
        if(i==1){
            printf("%d",num[i]);
        }
        else{
            printf(" %d",num[i]);
        }
    }
    return 0;
}

 




posted @ 2019-03-11 20:14  Tonyyy  阅读(226)  评论(0编辑  收藏  举报