hdu 2058 The sum problem

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19608    Accepted Submission(s): 5786


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

 

Sample Input
20 10
50 30
0 0
 

 

Sample Output
[1,4]
[10,10]
 
[4,8]
[6,9]
[9,11]
[30,30]
 

 

Author
8600
题意:给两个值n,m,表示一个长度为n的数列,让你从这个数列中找出所有连续的子序列使他们的和为m
 
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MAX 1001000
using namespace std;
struct node
{
	int a,b;
}s[MAX];
bool cmp(node x,node y)
{
	return x.a<y.a;
}
int main()
{
	int n,m,j,i,t,k;
	t=0;
	while(scanf("%d%d",&n,&m),n|m)
	{
		int ans=sqrt(2*n);
		int x;k=0;
		for(i=1;i<=ans;i++)
		{
			x=(2*m+i-i*i)/2/i;
			if((2*x+i-1)*i==2*m&&x>0&&(i%2==0||(2*x+i-1)%2==0))
			{
				s[k].a=x;
				s[k++].b=x+(i-1);
			}
		}
		sort(s,s+k,cmp);
		for(i=0;i<k;i++)
		printf("[%d,%d]\n",s[i].a,s[i].b);
		t++;
		printf("\n");
	}
	return 0;
}

  

posted @ 2015-11-25 17:17  非我非非我  阅读(148)  评论(0编辑  收藏  举报