hdu 2715 Herd Sums

Herd Sums

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 772    Accepted Submission(s): 375


Problem Description
The cows in farmer John's herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N.

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem.
 

 

Input
* Line 1: A single integer: N
 

 

Output
* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.
 

 

Sample Input
15
 

 

Sample Output
4

 根据等差数列求和公式S=(a1+an)*n/2和末项公式an=a1+(n-1)*d(d位公差)得a1=(2*s+n-n*n)/2/n;得出求a1的公式然后对所有的n(n为项数)进行枚举,得出结果

2*s=(2*a1+n-1)*n所以n为偶数或者(2*a1+n-1)为偶数且a1不等于0

#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
	int n,m,j,i;
	while(scanf("%d",&n)!=EOF)
	{
		int ans=sqrt(2*n);
		int ant=0;
		for(i=1;i<=ans;i++)
		{
			m=(2*n+i-i*i)/2/i;
			if(2*m*i+i*i-i==2*n&&m>0&&(i%2==0||(2*m+i-1)%2==0))
			    ant++;
		}
		printf("%d\n",ant);
	}
	return 0;
}

  

posted @ 2015-11-24 15:50  非我非非我  阅读(496)  评论(0编辑  收藏  举报