poj 1458 Common Subsequence【LCS】

Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 43132   Accepted: 17472

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

虽然还没有太理解这个算法,不过还是先贴上吧
#include<stdio.h>
#include<string.h>
#define MAX 1100
#define maxn(x,y)(x>y?x:y)
char s1[MAX],s2[MAX];
int dp[MAX][MAX];
int main()
{
	int i,j,len1,len2;
	memset(dp,0,sizeof(dp));
	while(scanf("%s%s",s1,s2)!=EOF)
	{
		len1=strlen(s1);
		len2=strlen(s2);
		for(i=1;i<=len1;i++)
		{
			for(j=1;j<=len2;j++)
		    {
		    	if(s1[i-1]==s2[j-1])
		    	dp[i][j]=dp[i-1][j-1]+1;
		    	else
		    	dp[i][j]=maxn(dp[i][j-1],dp[i-1][j]);
			}
		}
		printf("%d\n",dp[len1][len2]);
	}
	return 0;
}

  

posted @ 2015-08-10 10:06  非我非非我  阅读(183)  评论(0编辑  收藏  举报