hdoj 2524 矩形A + B【递推】

矩形A + B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5187    Accepted Submission(s): 4034


Problem Description
给你一个高为n ,宽为m列的网格,计算出这个网格中有多少个矩形,下图为高为2,宽为4的网格.
 

 

Input
第一行输入一个t, 表示有t组数据,然后每行输入n,m,分别表示网格的高和宽 ( n < 100 , m < 100).
 

 

Output
每行输出网格中有多少个矩形.
 

 

Sample Input
2
1 2
2 4
 

 

Sample Output
3
30
#include<stdio.h>
int main()
{
	int t,n,m,s;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		s=((n+1)*n/2)*((m+1)*m)/2);
		printf("%d\n",s);
	}
	return 0;
}

 

posted @ 2015-08-01 12:14  非我非非我  阅读(106)  评论(0编辑  收藏  举报