nyoj 483 Nightmare【bfs+优先队列】
Nightmare
时间限制:1000 ms | 内存限制:65535 KB
难度:4
- 描述
-
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.
Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.
Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
- 输入
- The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas. - 输出
- For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
- 样例输入
-
2 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3
- 样例输出
-
4 -1
题意是:起点为2终点为3 炸弹会在6分钟内爆炸(当刚好走出迷宫剩余时间为0也会爆炸) 必须在炸弹爆炸之前走出迷宫
当遇到4时时间可以重置为6 当走到4时剩下时间为0则不能重置时间,如果可以在规定时间内走出迷宫则输出走的步数
否则输出-112345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define MAX 10
using
namespace
std;
int
map[MAX][MAX];
int
vis[MAX][MAX];
int
n,m,t,sum;
int
x1,x2,y1,y2;
struct
node
{
int
x,y;
int
step,
time
;
friend
bool
operator < (node a,node b)
{
return
a.step>b.step;
}
};
void
bfs()
{
int
move[4][2]={0,1,0,-1,1,0,-1,0};
int
i,j;
priority_queue<node>q;
node beg,end;
beg.x=x1;
beg.y=y1;
beg.step=0;
beg.
time
=6;
//用来记录在遇到可以重置时间(4)之前走了多少步
q.push(beg);
vis[x1][y1]=1;
while
(!q.empty())
{
end=q.top();
q.pop();
if
(end.x==x2&&end.y==y2)
{
printf
(
"%d\n"
,end.step);
return
;
}
if
(end.
time
==1)
//判断当剩下一步的时候是否到达终点(因为当剩下0步时即使是
//到了可以重置时间的地方也没用)
continue
;
for
(i=0;i<4;i++)
{
beg.x=end.x+move[i][0];
beg.y=end.y+move[i][1];
if
(0<=beg.x&&beg.x<n&&0<=beg.y&&beg.y<m&&map[beg.x][beg.y]!=0)
{
if
(map[beg.x][beg.y]==4)
//当遇到4
{
beg.
time
=6;
//步数时间重新变为6
map[beg.x][beg.y]=0;
}
else
beg.
time
=end.
time
-1;
//否则 走一步时间减1
beg.step=end.step+1;
q.push(beg);
}
}
}
printf
(
"-1\n"
);
}
int
main()
{
int
i,j,k,s;
scanf
(
"%d"
,&t);
while
(t--)
{
scanf
(
"%d%d"
,&n,&m);
for
(i=0;i<n;i++)
{
for
(j=0;j<m;j++)
{
scanf
(
"%d"
,&map[i][j]);
}
}
for
(i=0;i<n;i++)
{
for
(j=0;j<m;j++)
{
if
(map[i][j]==2)
{
x1=i;y1=j;
}
if
(map[i][j]==3)
{
x2=i;y2=j;
}
}
}
sum=0;
memset
(vis,0,
sizeof
(vis));
bfs();
}
return
0;
}
【推荐】还在用 ECharts 开发大屏?试试这款永久免费的开源 BI 工具!
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 从二进制到误差:逐行拆解C语言浮点运算中的4008175468544之谜
· .NET制作智能桌面机器人:结合BotSharp智能体框架开发语音交互
· 软件产品开发中常见的10个问题及处理方法
· .NET 原生驾驭 AI 新基建实战系列:向量数据库的应用与畅想
· 从问题排查到源码分析:ActiveMQ消费端频繁日志刷屏的秘密
· C# 13 中的新增功能实操
· Ollama本地部署大模型总结
· 【杭电多校比赛记录】2025“钉耙编程”中国大学生算法设计春季联赛(4)
· langchain0.3教程:从0到1打造一个智能聊天机器人
· 2025成都.NET开发者Connect圆满结束