hdoj 1003 Max Sum

Max Sum

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 5
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1:
14 1 4
 
 
Case 2:
7 1 6
 
#include<stdio.h>
#include<string.h>
#define MAX 100000+10
#define INF 0x3f3f3f
int main()
{
	int n,m,j,i,k1,k2,t,sum;
	int x,y,sum1;
	int s[MAX];
	scanf("%d",&t);
	m=1;
	while(t--)
	{
		memset(s,0,sizeof(s));
		scanf("%d",&n);
		for(i=0;i<n;i++)
	    {
	    	scanf("%d",&s[i]);
	    }
	    x=y=k1=k2=0;
	    sum=s[0];
	    sum1=sum;
	    for(i=1;i<n;i++)
	    {
	    	if(sum>=0)
	    	{
	    		y=i;
	    		sum+=s[i];
	    	}
	    	else
	    	{
	    		x=i;
	    		y=i;
	    		sum=s[i];	
	    	}
	    	if(sum>sum1)
	    	{
	    		sum1=sum;
	    		k1=x;
	    		k2=y;
	    	}
	    }
	    printf("Case %d:\n",m++);
	    printf("%d %d %d\n",sum1,k1+1,k2+1);
	    if(t!=0)
	    printf("\n");
	} 
	return 0;
}

  

posted @ 2015-06-25 19:04  非我非非我  阅读(188)  评论(0编辑  收藏  举报