hdoj 1162 Eddy's picture

并查集+最小生成树

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7669    Accepted Submission(s): 3882


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

 

Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0
 

 

Sample Output
3.41
 
kruskal算法
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int set[110];
struct record//注意此题要用实型
{
	double a;     
	double b;
	double ju;//两点之间距离 
}s[10000];
int find(int fa)
{
	int ch=fa;
	int t;
	while(fa!=set[fa])
	fa=set[fa];
	while(ch!=fa)
	{
		t=set[fa];
		set[ch]=fa;
		ch=t;
	}
	return fa;
}
void mix(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	set[fx]=fy;
}
double dis(double x1,double y1,double x2,double y2)
{
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)); //计算两点之间距离 
}
bool cmp(record c,record d)
{
	return c.ju<d.ju;   
}
int main()
{
	int m,j,i,point;
	double sum;
	double a[110];//这两个数组用来储存点的坐标,a数组储存横标 
	double b[110];//b数组储存纵标 
	while(scanf("%d",&point)!=EOF)
	{
		for(i=0;i<=point;i++)
		set[i]=i;
		for(i=1;i<=point;i++)
		{
			scanf("%lf%lf",&a[i],&b[i]);
		}
		m=0;
		for(i=1;i<=point-1;i++)    //此循环求任意两点之间距离 
		{                          //并记录下此两点位置 
			for(j=i+1;j<=point;j++)
			{
				s[m].ju=dis(a[i],b[i],a[j],b[j]);
				s[m].a=i;
				s[m].b=j;
				m++;				
			}
		}
	    sort(s,s+m,cmp);
		sum=0;
		for(i=0;i<m;i++)
		{
			if(find(s[i].a)!=find(s[i].b))
			{
				mix(s[i].a,s[i].b);
				sum+=s[i].ju;
			}
		}
		printf("%.2lf\n",sum);
	}
    return 0;	
}

  

 
posted @ 2015-05-01 17:42  非我非非我  阅读(255)  评论(0编辑  收藏  举报