Fliptile POJ - 3279

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

思路

二进制枚举第一行的翻转情况,第二行的开关情况由第一行的01情况决定,从而一行一行下去,最后特判一下最后一行是不是全0就行了。

#include<iostream>
#include<cstring>

using namespace std;

const int N = 30;

int g[N][N], backup[N][N];
int m, n;
int a[N][N], b[N][N];
int dx[] = {1, 0, -1, 0, 0}, dy[] = {0, 1, 0, -1, 0};

void turn(int x, int y){
    for(int i = 0; i < 5; i ++){
        int a = x + dx[i], b = y + dy[i];
        if(a < 0 || a >= m || b < 0 || b >= n) continue;
        g[a][b] ^= 1;
    }
}


int main(){
    cin >> m >> n;
    
    for(int i = 0; i < m; i ++)
        for(int j = 0; j < n; j ++)
            cin >> g[i][j];
    
    memcpy(backup, g, sizeof g);
    
    int res = 0x3f3f3f3f;
    
    for(int i = 0; i <= (1 << n) - 1; i ++){
        int step = 0;
        for(int j = 0; j < n; j ++)
            if(i >> j & 1){
                step ++;
                a[0][j] ++;
                turn(0, j);
            }
        
        for(int j = 1; j < m; j ++){
            for(int k = 0; k < n; k ++)
                if(g[j - 1][k] == 1){
                    step ++;
                    a[j][k] ++;
                    turn(j, k);
                }
        }
        
        int flag = 0;
        for(int j = 0; j < n; j ++){
            if(g[m - 1][j] == 1){
                flag = 1;
                break;
            }
        }
        
        if(!flag){
            if(step < res){
                res = step;
                memcpy(b, a, sizeof a);
            }
        }
        memcpy(g, backup, sizeof backup);
        memset(a, 0, sizeof a);
    }
    if(res == 0x3f3f3f3f) cout << "IMPOSSIBLE" << endl;
    else
        for(int i = 0; i < m; i ++){
            for(int j = 0; j < n; j ++)
                cout << b[i][j] << ' ';
            cout << endl;
        }
    return 0;
}
posted @ 2020-08-03 21:31  yys_c  阅读(84)  评论(0编辑  收藏  举报