hdu 1258 Sum It Up

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2906    Accepted Submission(s): 1455


Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 
Sample Input
 
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0
 
Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25
Source
 
/*
很好的一个题目,杭电的测试数据太水,很多人在hdu ac了,但poj确实wr,建议到poj上试一试。
dfs修改了一个下午。
这道题,搜索的优化
1.排序后搜索,用到for(i=x+1;i<=m;i++)
为了解决重复,采取两个栈的比较,由于从大到小,所以不会出现超过2次后又出现重复的。
*/
#include<stdio.h>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<string.h>
using namespace std;
int f[102];
int visit[102];
int flag1[102],flag2[102];
int a[102];
int n,m,glag;
int zhan1[102],zhan2[102],len;
bool cmp(int b,int c)
{
    return b>c;
}
void dfs(int x,int p,int k)
{
    int i,j;
    if(k==1)
    {
        j=0;
        for(i=1;i<=len;i++)
            if(zhan1[i]!=zhan2[i]) {j=1;break;}
        if(j==1)
        {
            for(i=1;i<=len;i++)
            {
                if(i==1) printf("%d",zhan2[i]);
                else printf("+%d",zhan2[i]);
                if(i==len)printf("\n");
            }
            for(i=1;i<=len;i++)
                zhan1[i]=zhan2[i];
            glag=1;
        }
        k=0; //注意位置,很明显
        return; //避免了对后面的继续遍历,算是一种优化。
    }
    for(i=x+1;i<=m;i++)
        if(visit[i]==0)
        {
            if(p+f[i]>n)
                continue;
            visit[i]=1;
            if(p+f[i]==n)
            {
                k=1;
            }
            zhan2[++len]=f[i];
            dfs(i,p+f[i],k);
            --len; //注意到了没有 p=p-f[i];对的。因为dfs(...p+f[i]..)  )
            visit[i]=0;
            k=0; //此时也要k=0,很重要,建议动手实现一下流程。
            if(f[i]==f[i+1] &&i+1<=m)
            {
                while(f[i]==f[i+1] && i+1<=m)
                    i++;
                //i--; 刚开始i--,错误的。
            }
        }
}
int main()
{
    int i;
    while(scanf("%d%d",&n,&m)>0)
    {
        if(n==0&&m==0) break;
        for(i=1;i<=m;i++)
            scanf("%d",&f[i]);
        sort(f+1,f+1+m,cmp);
        for(i=1;i<=m;i++)
            visit[i]=0;
        printf("Sums of %d:\n",n);
        glag=0;len=0;
        memset(zhan1,0,sizeof(zhan1));
        memset(zhan2,0,sizeof(zhan2));
        dfs(0,0,0);
        if(glag==0) printf("NONE\n");
    }
    return 0;
}

 

posted @ 2013-07-17 07:56  芷水  阅读(155)  评论(0编辑  收藏  举报