POJ 1703 Find them, Catch them

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24739   Accepted: 7435

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

并查集
复制代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int f[100003];
int rank[100003];
void makeini(int n)
{
    int i;
    for(i=1;i<=n;i++)
    {
        rank[i]=0;
        f[i]=i;
    }
}
int find(int x)
{
    int t;
    if(x==f[x])
        return x;
    t=find(f[x]);
    rank[x]=(rank[x]+rank[f[x]])%2;
    f[x]=t;
    return t;
}
void Union(int x,int y)
{
    int x1,y1;
    x1=find(x);
    y1=find(y);
    if(x1==y1)
        return ;
    else
    {
        f[x1]=y1;
        rank[x1]=(rank[x]+rank[y]+1)%2;
    }
}
int main()
{
    int t,i,n,m,x,y,x1,y1;
    char c[5];
    scanf("%d",&t);
    {
        while(t--)
        {
            scanf("%d%d",&n,&m);
            makeini(n);
            for(i=1;i<=m;i++)
            {
                scanf("%s%d%d",c,&x,&y);
                if(c[0]=='A')
                {
                    x1=find(x);
                    y1=find(y);
                    if(x1==y1)
                    {
                        if(rank[x]==rank[y])
                            printf("In the same gang.\n");
                        else printf("In different gangs.\n");
                    }
                    else printf("Not sure yet.\n");
                }
                if(c[0]=='D')
                {
                    Union(x,y);
                }
            }
        }
    }
    return 0;
}
复制代码

 

posted @   芷水  阅读(222)  评论(0编辑  收藏  举报
编辑推荐:
· 用 C# 插值字符串处理器写一个 sscanf
· Java 中堆内存和栈内存上的数据分布和特点
· 开发中对象命名的一点思考
· .NET Core内存结构体系(Windows环境)底层原理浅谈
· C# 深度学习:对抗生成网络(GAN)训练头像生成模型
阅读排行:
· 趁着过年的时候手搓了一个低代码框架
· 本地部署DeepSeek后,没有好看的交互界面怎么行!
· 为什么说在企业级应用开发中,后端往往是效率杀手?
· 用 C# 插值字符串处理器写一个 sscanf
· 乌龟冬眠箱湿度监控系统和AI辅助建议功能的实现
点击右上角即可分享
微信分享提示