HDU 356 S-Nim

S-Nim

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2958 Accepted Submission(s): 1314


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player's last move the xor-sum will be 0.

The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

 

Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
 

 

Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3 2 5 12
3
2 4 7
4 2 3 7 12
0
 
Sample Output
LWW
WWL
 
Source
 

 

Recommend
LL
 
 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int f[101][101];
int arry[101];
int SG[10002];
int getsg(int num)
{
    int i,tmp,hash[101]={0};
    for(i=1;i<=arry[0];i++)
    {
        if(arry[i]>num)
            break;
        tmp=num-arry[i];
        if(SG[tmp]==-1)
            SG[tmp]=getsg(tmp);
        hash[SG[tmp]]=1;
    }
    for(i=0;;i++)
        if(hash[i]==0)
            return i;
}
void px()
{
    int i,j,k,tmp;
    for(i=1;i<arry[0];i++)
    {
        k=i;
        for(j=i+1;j<=arry[0];j++)
            if(arry[k]>arry[j])
                k=j;
        tmp=arry[k];
        arry[k]=arry[i];
        arry[i]=tmp;
    }
}
int main()
{
    int i,j,k,n,m,tmp,max;
    while(scanf("%d",&n)>0)
    {
        if(n==0)break;
        arry[0]=n;
        for(i=1;i<=n;i++)
            scanf("%d",&arry[i]);
        px();
        scanf("%d",&m);
        for(i=1,max=0;i<=m;i++)
        {
            scanf("%d",&k);
            f[i][0]=k;
            for(j=1;j<=k;j++)
            {
                scanf("%d",&f[i][j]);
                if(f[i][j]>max)
                    max=f[i][j];
            }
        }
        memset(SG,-1,sizeof(SG));
        for(i=1;i<=m;i++)
        {
            k=0;
            for(j=1;j<=f[i][0];j++)
            {
                tmp=f[i][j];
                k=k^getsg(tmp);
            }
            if(k==0) printf("L");
            else printf("W");
        }
        printf("\n");
    }
    return 0;
}

 

 
posted @ 2013-05-31 07:43  芷水  阅读(157)  评论(0编辑  收藏  举报