HDU 2509 Be the Winner

Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1291    Accepted Submission(s): 667

Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time. For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 
Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 
Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 
Sample Input
2
2 2
1
3
 
Sample Output
No
Yes
 
Source
 
Recommend
lcy
 
 
和上一题,一样的。。。。。。⊙﹏⊙
 
#include<stdio.h>
int f[102];
int main()
{
    int i,n,m,num1,num2;
    while(scanf("%d",&n)>0)
    {
        m=0;num1=0;num2=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&f[i]);
            m=m^f[i];
            if(f[i]==1)num1++;
            if(f[i]>1) num2++;
        }
        if(m==0)
        {
            if(num2>=2)
                printf("No\n");
            else printf("Yes\n");
        }
        if(m>0)
        {
            if(num1==n)
                printf("No\n");
            else printf("Yes\n");
        }
    }
    return 0;
}

 

posted @ 2013-05-28 17:51  芷水  阅读(148)  评论(0编辑  收藏  举报