HDU 1548 A strange lift

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 
Sample Input
5 1 5 3 3 1 2 5 0
 
Sample Output
3
 
 
 
这是一道典型是BFS搜索题,不过鉴于题目的限制,用通常的BFS搜索方法并不能解决这道题,反而会超过限制。
所以根据BFS的特性,我们可以将该题数据抽象成一副有向图,起点就是A,终点是B,求两者间最短路径,并利用队列逐层搜索。
 每当到下一层时就将队列中上一个元素逐个弹出以此节省空间。
必须知道的是,为了得到最小的步数,我们可以将已走过的层数全部做标记。
当再次走过这些点时哪怕能得到最终结果也并非最短,哪怕通过这些点不能得到最终结果再次走到这些点时也没有意义,这就是这题的优化剪枝。
 
AC代码如下:
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;

int main()
{
    int fl[201];
    int N, A, B;
    int i, up, down, minstep;
    queue<int> sq;
    while(cin>>N&&N)
    {
        cin>>A>>B;
        for(i=1;i<=N;i++)   cin>>fl[i];
        minstep = 0;
        sq.push(A);
        int flag=0;
        while(true)
        {
            int temp = sq.size();
            for(i=1;i<=temp;i++)
                {
                    int num = sq.front();
                    if(num==B)  {   while(!sq.empty())  sq.pop(); flag=1;  break;}
                    sq.pop();
                    down = num - fl[num];
                    up = num + fl[num];
                    if(down>=1&&fl[num]!=-1)  { sq.push(down); }
                    if(up<=N&&fl[num]!=-1)   { sq.push(up); }
                    fl[num] = -1;
                }
            if(!sq.empty())  minstep++;
            else    break;
        }
        if(flag)    cout<<minstep<<endl;
        else            cout<<-1<<endl;
        while(!sq.empty())  sq.pop();
    }
    return 0;
}

 

posted @ 2017-03-13 08:22  明早六点起  阅读(119)  评论(0编辑  收藏  举报