A+B for Input-Output Practice (VIII) <入门练手题>

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14899    Accepted Submission(s): 4837
 
Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
 
Sample Output
10

15

6
 
代码:
#include<stdio.h>
int main(void)
{
	int a,b,i,N,M;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d",&M);
		for(i=0,b=0;i<M;i++)
		{
			scanf("%d",&a);
			b+=a;
		}
		printf("%d\n",b);
		if(i!=0) printf("\n");
	}
    return 0;
}

注意:初次可能会将输出部分错误写成“printf("%d\n\n",b);”,而题目要求是在输出结果间间隔一行,也就是说当只有一个输出结果时,错误的写法会造成此时的输出结果后面有一行空格!!

  

posted @ 2012-10-09 19:03  莫邪257  阅读(575)  评论(0编辑  收藏  举报