A+B for Input-Output Practice (VI) <入门练手题>

A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6723    Accepted Submission(s): 4856
 
Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.
 
Output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.
 
Sample Input
4 1 2 3 4
5 1 2 3 4 5
 
Sample Output
10
15
 
代码:
#include<stdio.h>
int main(void)
{
	int a,b,i,N;
	while(scanf("%d",&N)!=EOF)
	{
		for(i=0,b=0;i<N;i++)
		{
			scanf("%d",&a);
			b+=a;
		}
		printf("%d\n",b);
	}
	return 0;
}

  

posted @ 2012-10-09 18:57  莫邪257  阅读(245)  评论(0编辑  收藏  举报