A+B for Input-Output Practice (IV) <入门练手题>

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8510    Accepted Submission(s): 5170
 
Problem Description
Your task is to Calculate the sum of some integers.
 
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0 
 
Sample Output
10
15
 
代码:
#include<stdio.h>
int main(void)
{
	int i,a,b,N;
	while(scanf("%d",&N),N)
	{
	  for(i=0,b=0;i<N;i++)
	  {
  		scanf("%d",&a);
  		b+=a;
  	  }
         printf("%d\n",b);
	 }
        return 0;
}

  

posted @ 2012-10-09 18:53  莫邪257  阅读(373)  评论(0编辑  收藏  举报