A+B for Input-Output Practice (II) <入门练手题>

A+B for Input-Output Practice (II)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8117    Accepted Submission(s): 5778
 
Problem Description
Your task is to Calculate a + b.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.
 
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 
Sample Input
2
1 5
10 20
 
Sample Output
6
30
 
代码:
代码一:
#include<stdio.h>
int main(void)
{
	int N,a,b;
	scanf("%d",&N);
	while(N--)
	{
	  scanf("%d %d",&a,&b);
	  printf("%d\n",a+b);
	}
	return 0;
}
 
代码二:
#include<stdio.h>
int main(void)
{
	int a,b,N;
	scanf("%d",&N);
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		printf("%d\n",a+b);
	}
	return 0;
}

  

posted @ 2012-10-09 18:46  莫邪257  阅读(495)  评论(0编辑  收藏  举报