PAT 1093

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 1 characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2


复制代码
#include <bits/stdc++.h>
using namespace std;
#define N 100010
#define P pair<int,int>
#define mod 1000000007
#define ll long long 
//APPAPT 有几个不重复的PAT 
char s[N];
ll p[N],t[N];
int main()
{
    scanf("%s",s);
    int l =strlen(s);
    if(s[0]=='P') p[0]=1;//因为p[-1] 
    for(int i =1;i<l;i++){
        if(s[i]=='P'){
            p[i]=p[i-1]+1;
        }
        else{
            p[i] = p[i-1];
        }
    }
    for(int i=l-1;i>=0;i--){
        if(s[i]=='T'){
            t[i]=t[i+1]+1;
        }
        else{
            t[i] = t[i+1];
        }
    }
    ll  ans = 0;
    for(int  i=0;i<l;i++){
        if(s[i]=='A'){
            ll  x=p[i-1];
            ll  y=t[i+1];
            ans=(ans+x*y%mod)%mod;
        }
    }
    printf("%lld\n",ans);    
    return 0;
}
复制代码

 

posted on   cltt  阅读(116)  评论(0编辑  收藏  举报

编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 25岁的心里话
· 按钮权限的设计及实现
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

统计

点击右上角即可分享
微信分享提示