快排 PAT 1101

1101 Quick Sort (25 分)
 

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then the next line contains N distinct positive integers no larger than 1. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5




复制代码
#include <bits/stdc++.h>
using namespace std;
#define N 100010
int  a[N],n;
int vis[N];
vector<int>ve;
//有多少个数它左边比它小,右边比它大 
int main()
{
    scanf("%d",&n);
    for(int  i=1;i<=n;i++) scanf("%d",&a[i]);
    for(int i =1;i<=n;i++) vis[i] = 1;
    int maxx = a[1];
    //因为是N个不同的数,那么从左到右应该是递增
    //只要不满足这个条件,就一定不是,逆序时同理 
    for(int i =1;i<=n;i++){
        if(a[i]<maxx) vis[i] = 0;
        else{
            maxx = a[i];
        }
    }
    int minn  =a[n];
    for(int  i=n;i>=1;i-- ){
        if(a[i]>minn) vis[i] = 0;
        else {
            minn  =a[i];
        }
    }
    int cnt  = 0;
    for(int i =1;i<=n;i++){
        if(vis[i]==1) 
        {    
         cnt++;
        ve.push_back(a[i])    ;
          } 
    }
    if(cnt==0) printf("0\n\n");
    else{
        printf("%d\n",cnt);
        sort(ve.begin(),ve.end());
        for(int  i =0;i<ve.size();i++){
            if(i==0) printf("%d",ve[i]);
            else{
                printf(" %d",ve[i]);
            }
        }
    }
     return 0;
}
复制代码

 

 

posted on   cltt  阅读(155)  评论(0编辑  收藏  举报

编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 25岁的心里话
· 按钮权限的设计及实现
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

统计

点击右上角即可分享
微信分享提示