PAT 1098

1098 Insertion or Heap Sort (25 分)
 

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

//直接插入排序和堆排序

复制代码
#include <bits/stdc++.h>
using namespace std;
#define N 120
int  n,a[N],b[N],heap[N];
int  flag  = 0;
bool same(int *a,int *b){
    for(int i=1;i<=n;i++) {
        if(a[i]!=b[i]) return  false;
    }
    return  true;
}
void insert_sort(int *a){
    for(int i =2;i<=n;i++){//2不是1,因为堆排序输入的可能也是第一次排好的 
        sort(a+1,a+i+1);
        if(flag!=0) break;
        if(same(a,b)) flag  =1;
    }
}
void downjust(int l,int h){
    int i =l;
    int j =2*i;
    while(j<=h){
        if(j+1<=h&&heap[j]<heap[j+1]){
            j=j+1;
        }
        if(heap[j]>heap[i]){
            swap(heap[i],heap[j]);
            i=j;
            j=2*i;
        }
        else
        break;
    }
}
void create(int *a){
    for(int i =n/2;i>=1;i--){
        downjust(i,n);
    }
}
void heap_sort(int *a){
    for(int i=n;i>1;i--){
        swap(heap[i],heap[1]);
        downjust(1,i-1);
        if(flag!=0) break;
        if(same(heap,b)) flag  =2;
    }
} 
int main(){
    scanf("%d",&n);
    for(int i =1;i<=n;i++) 
    {
    scanf("%d",&a[i]);
    heap[i] = a[i]    ;
}
for(int  i=1;i<=n;i++){
    scanf("%d",&b[i]);
}
insert_sort(a);
create(heap);
heap_sort(heap);//heap 
if(flag==1){
    printf("Insertion Sort\n");
    for(int  i =1;i<=n;i++) {
        printf("%d%c",a[i],i==n?'\n':' ');
    }
}
else if(flag  ==2){
    printf("Heap Sort\n");
    for(int  i =1;i<=n;i++) {
        printf("%d%c",heap[i],i==n?'\n':' ');
    }
}
    return 0;
}
复制代码

 

 

posted on   cltt  阅读(176)  评论(0编辑  收藏  举报

编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 25岁的心里话
· 按钮权限的设计及实现
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

统计

点击右上角即可分享
微信分享提示