PAt 1099

1099 Build A Binary Search Tree (30 分)
 

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N1, and 0 is always the root. If one child is missing, then − will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42



复制代码
//根据二叉树的结构和中序遍历来写出层序遍历 
#include <bits/stdc++.h>
using namespace std;
#define N 120
#define P pair<int,int>
struct Tree{
    int val,l,r;
    Tree(){
    }
    Tree(int val,int  l,int r):val(val),l(l),r(r){
    }
}tr[N];
int a[N],b[N],n;
//不需要建树,题目输入的就是了  
int cnt2=0;
void search(int rt){//中序 
    if(rt==-1) return ;
    search(tr[rt].l);
    tr[rt].val=a[cnt2++];
    search(tr[rt].r);
}
int cnt = 0;
void dfs(int rt){//层序遍历 
    queue<P>q;
    q.push(P(rt,tr[rt].val));
    int  flag =1;
    while(!q.empty()){
        P p =q.front();q.pop();
        int x=p.first,y=p.second;
        //输出格式 
        if(flag){
            printf("%d",y);
            flag =0;
        }
        else{
            printf(" %d",y);
        }
        int num1 = tr[x].l;
        int num2=  tr[x].r;
        if(num1!=-1){
            q.push(P(num1,tr[num1].val));
        }
        if(num2!=-1){
            q.push(P(num2,tr[num2].val));
        }
    }
}
int main()
{
    scanf("%d",&n);
    for(int i =0;i<n;i++){
        scanf("%d%d",&tr[i].l,&tr[i].r);
    }
    for(int i =0;i<n;i++) scanf("%d",&a[i]);
    sort(a,a+n);
    search(0);
    dfs(0);
    return 0;
}
复制代码

 

posted on   cltt  阅读(137)  评论(0编辑  收藏  举报

编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 25岁的心里话
· 按钮权限的设计及实现
历史上的今天:
2018-09-18 zoj 4057
2018-09-18 zoj 4056
2018-09-18 zoj 4054
2018-09-18 zoj 4049
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

统计

点击右上角即可分享
微信分享提示