POJ1481 ZOJ1191 UVA657 UVALive5628 The die is cast【双重DFS】

The Die Is Cast
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1113 Accepted: 448

Description

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.
Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three different pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

在这里插入图片描述

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence a1, a2, ..., ak in S such that a = a1 and b = ak , and ai and ai+1 are connected for 1 <= i < k.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy 5 <= w, h <= 50.

The following h lines contain w characters each. The characters can be: "." for a background pixel, "*" for a pixel of a die, and "X" for a pixel of a die's dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input

30 15
..............................
..............................
.............................
...*****......
............
...
X
.....X...........
...
....X............
...
X..................
...*****.......
..............
..............................
........
.............
.......
X
.....X**X.....
.................
.....
X**.......X**X.....
........
........****.....
..............................
0 0

Sample Output

Throw 1
1 2 2 4

Source

Southwestern European Regional Contest 1998

Regionals 1998 >> Europe - Southwestern

问题链接POJ1481 ZOJ1191 UVA657 UVALive5628 The die is cast
问题简述:(略)
问题分析
    计算*号区域的骰子数量,连在一起的算一个。
    使用双重DFS实现。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1481 ZOJ1191 UVA657 UVALive5628 The die is cast */

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 50;
char grid[N][N + 1];
int vis[N][N];
int h, w;
int sum[N * N], cnt;

void dfsX(int row, int col)
{
    if(row >= 0 && row < h && col >= 0 && col < w && vis[row][col] != 2)
        if(grid[row][col] == 'X') {
            vis[row][col] = 2;      // 标记为访问过
            dfsX(row - 1, col);
            dfsX(row, col + 1);
            dfsX(row + 1, col);
            dfsX(row, col - 1);
        }
}

void dfs(int row, int col)
{
    if(row >= 0 && row < h && col >= 0 && col < w) {
        if(vis[row][col] != 1 && grid[row][col] != '.') {
            if (grid[row][col] == 'X' && vis[row][col] != 2) {     // 点处理
               sum[cnt]++;
               dfsX(row, col);
            }

            vis[row][col] = 1;      // 标记为访问过
            dfs(row - 1, col);
            dfs(row, col + 1);
            dfs(row + 1, col);
            dfs(row, col - 1);
        }
    }
}

int main()
{
    int i, j, caseno = 0;
    while (~scanf("%d%d", &w, &h) && (w || h)) {
        getchar();
        for(int i = 0; i < h; i++)
            gets(grid[i]);

        memset(vis, 0, sizeof(vis));

          cnt = 0;
          for (i = 0; i < h; i++)
              for (j = 0; j < w; j++){
                  if (vis[i][j] != 1 && grid[i][j] != '.') {
                     sum[cnt] = 0;
                     dfs(i, j);
                     if (sum[cnt])
                         cnt++;
                  }
              }

          sort(sum, sum + cnt);

          printf("Throw %d\n", ++caseno);
          for (i = 0, cnt--; i < cnt; i++)
              printf("%d ", sum[i]);
          printf("%d\n\n", sum[cnt]);
    }
    return 0;
}

posted on 2019-03-14 16:22  新海岛Blog  阅读(155)  评论(0编辑  收藏  举报

导航

// ... runAll: function() { this.resetPreCode(); hljs.initHighlightingOnLoad(); // 重新渲染,添加语法高亮 hljs.initLineNumbersOnLoad(); // 为代码加上行号 } // ...