POJ2258 ZOJ1947 UVA539 The Settlers of Catan【DFS】
The Settlers of Catan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1543 Accepted: 1012
Description
Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.
You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:
When the game ends, the player who built the longest road gains two extra victory points.
The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).
Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes.
The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.
Example: The following network contains a road of length 12.
Input
The input will contain one or more test cases.
The first line of each test case contains two integers: the number of nodes n (2<=n<=25) and the number of edges m (1<=m<=25). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.
Input will be terminated by two values of 0 for n and m.
Output
For each test case, print the length of the longest road on a single line.
Sample Input
3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0
Sample Output
2
12
Source
问题链接:POJ2258 ZOJ1947 UVA539 The Settlers of Catan
问题简述:(略)
问题分析:
一个图,有n个结点m条边,每条边长度为1。从某个结点出发,结点可以重复通过,边只可通过1次,计算可以走的最长距离是多少?
任意一条边都作为起点,深度搜索其最长长度。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* POJ2258 ZOJ1947 UVA539 The Settlers of Catan */
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 25;
int g[N][N];
bool vis[N][N];
int n, m, ans;
void dfs(int u, int cnt)
{
ans = max(ans, cnt);
for(int v = 0; v < n; v++)
if(g[u][v] && !vis[u][v]) {
vis[u][v] = vis[v][u] = true; // 标记边
dfs(v, cnt + 1);
vis[u][v] = vis[v][u] = false;
}
}
int main()
{
while(~scanf("%d%d", &n, &m) && (n || m)) {
memset(g, 0, sizeof(g));
for(int i = 0; i < m; i++) {
int u, v;
scanf("%d%d", &u, &v);
g[u][v] = g[v][u] = 1;
}
ans = 0;
for(int i = 0; i < n; i++) {
memset(vis, false, sizeof(vis));
dfs(i, 0);
}
printf("%d\n", ans);
}
return 0;
}