POJ1218 HDU1337 ZOJ1350 UVALive2557 THE DRUNK JAILER

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 28334   Accepted: 17574

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the 
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He 
repeats this for n rounds, takes a final drink, and passes out. 
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n. 

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells. 

Sample Input

2
5
100

Sample Output

2
10

Source


Regionals 2002 >> North America - Greater NY


问题链接POJ1218 HDU1337 ZOJ1350 UVALive2557 THE DRUNK JAILER

题意简述输入n,n为5-100间的一个数,代表有多少间牢房。刚开始所有房间打开,第1轮2的倍数的房间门翻转(打开的关上,关上的打开),第2轮3的倍数,第3轮4的倍数,......,第n-1轮n的倍数。求最后有几间牢房门是打开的。

问题分析:使用模拟法,模拟这个过程即可。好在计算规模不算大。

程序说明:(略)


参考链接:(略)


AC的C语言程序如下:

/* POJ1218 HDU1337 ZOJ1350 UVALive2557 THE DRUNK JAILER */

#include <stdio.h>
#include <memory.h>

#define MAXN 100

int cell[MAXN+1];

int main(void)
{
    int t, n, sum, i, j;

    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);

        memset(cell, 0, sizeof(cell));

        for(i=2; i<=n; i++)
            for(j=i; j<=n; j++)
                if (j%i == 0)
                    cell[j] = 1 - cell[j];

        sum = 0;
        for(i=1; i<=n; i++)
            if(cell[i] == 0)
                sum++;

        printf("%d\n",sum);
    }

    return 0;
}

还有一种大牛做的,直接计算的方法,其数学道理真的不懂。AC的C语言程序如下:

/* POJ1218 THE DRUNK JAILER */

#include <stdio.h>
#include <math.h>

int main(void)
{
    int t, n, ans;

    scanf("%d",&t);
    while(t--) {
        scanf("%d", &n);

        ans = (int)sqrt(n);

        printf("%d\n", ans);
    }

    return 0;
}



posted on 2016-08-13 16:18  海岛Blog  阅读(141)  评论(0编辑  收藏  举报

导航