ZOJ3880 Demacia of the Ancients【序列处理+水题】

Demacia of the Ancients

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There is a popular multiplayer online battle arena game called Demacia of the Ancients. There are lots of professional teams playing this game. A team will be approved as Level K if there are exact K team members whose match making ranking (MMR) is strictly greater than 6000.

You are given a list of teams. Please calculate the level of each team.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 10) indicating the number of team members.

The second line contains N integers representing the MMR of each team member. All MMRs are non-negative integers less than or equal to 9999.

Output

For each test case, output the level of the given team.

Sample Input

3
5
7986 6984 6645 6200 6150
5
7401 7377 6900 6000 4300
3
800 600 200

Sample Output

5
3
0

Author: DAI, Longao
Source: The 12th Zhejiang Provincial Collegiate Programming Contest


问题链接ZOJ3880 Demacia of the Ancients

问题简述:参见上文。

问题分析这个题本质上是统计大于6000的数的个数。签到题,读懂题意就应该可以解决问题了。

程序说明:(略)

题记:(略)


AC的C++语言程序如下:

/* ZOJ3880 Demacia of the Ancients */

#include <iostream>
#include <stdio.h>

using namespace std;

const int MAXA = 6000;

int main()
{
    int t, n, a;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);

        int ans = 0;
        for(int i=1; i<=n; i++) {
            scanf("%d", &a);
            if(a > MAXA)
                ans++;
        }

        printf("%d\n", ans);
    }

    return 0;
}



posted on 2017-07-04 07:27  海岛Blog  阅读(108)  评论(0编辑  收藏  举报

导航