HDU3782 xxx定律【数学计算+水题】

xxx定律

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4872    Accepted Submission(s): 3556

Problem Description
对于一个数n,如果是偶数,就把n砍掉一半;如果是奇数,把n变成 3*n+ 1后砍掉一半,直到该数变为1为止。
请计算需要经过几步才能将n变到1,具体可见样例。
Input
测试包含多个用例,每个用例包含一个整数n,当n为0 时表示输入结束。(1<=n<=10000)
Output
对于每组测试用例请输出一个数,表示需要经过的步数,每组输出占一行。
Sample Input
3 1 0
Sample Output
5 0
Source

问题链接HDU3782 xxx定律

问题简述参见上文。

问题分析:这个问题也称作角谷猜想。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C语言程序如下:

/* HDU3782 xxx定律 */

#include <stdio.h>

int main(void)
{
    int n;
    while(scanf("%d", &n) != EOF && n) {
        int cnt = 0;

        while(n != 1) {
            if(n % 2)
                n = (3 * n + 1) / 2;
            else
                n /= 2;

            cnt++;
        }

        printf("%d\n", cnt);
    }

    return 0;
}




posted on 2017-07-24 21:20  海岛Blog  阅读(165)  评论(0编辑  收藏  举报

导航