HDU1017 ZOJ1152 A Mathematical Curiosity【暴力】

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42341    Accepted Submission(s): 13612

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input
1 10 1 20 3 30 4 0 0
Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
Source

问题链接HDU1017 ZOJ1152 A Mathematical Curiosity

问题简述参见上文。

问题分析:这个问题暴力枚举似乎最为合适。

程序说明:需要注意输出格式,测试数据有多组,每组的n和m以两个0结束,每组输出之间需要空1行。

题记:(略)


参考链接:(略)


AC的C++语言程序如下:

/* HDU1017 ZOJ1152 A Mathematical Curiosity */

#include <iostream>
#include <stdio.h>

using namespace std;

int countpair(int n, int m)
{
    int ans = 0;

    for(int b=1; b<=n-1; b++)
        for(int a=1; a<b; a++)
            if((a * a + b * b + m ) % (a * b) == 0)
                ans++;

    return ans;
}

int main()
{
    int t, n, m, caseno;

    scanf("%d", &t);
    while(t--) {
        caseno = 0;
        while(scanf("%d%d", &n, &m) != EOF && (n || m)) {
            printf("Case %d: %d\n", ++caseno, countpair(n, m));
        }

        if(t != 0)
            printf("\n");
    }

    return 0;
}


posted on 2017-07-27 23:40  海岛Blog  阅读(216)  评论(0编辑  收藏  举报

导航