UVALive6336 HDU4450 Draw Something【水题】

Draw Something

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3698    Accepted Submission(s): 3089

Problem Description

Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something.
Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say.
Input all the square Wangpeng draws, what’s the number in the picture?

Input
There are multiple test cases.
For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares.
Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap.
Input ends with N = 0.

Output
For each case, output the total area in one line.

Sample Input
4 1 2 3 4 3 3 3 3 0

Sample Output
30 27

Source

问题链接UVALive6336 HDU4450 Draw Something

问题简述:(略)

问题分析(略)

程序说明:不知道为什么在UVALive6336中出现WA,但是在HDU4450中是AC。

题记:程序员经常遇见郁闷的事情。


参考链接:(略)


AC的C++语言程序如下:

/* UVALive6336 HDU4450 Draw Something */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n, m, sum;
    while (scanf("%d", &n) != EOF && n) {
        sum = 0;
        while(n--) {
            scanf ("%d", &m);
            sum += m * m;
        }

        printf ("%d\n", sum);
    }

    return 0;
}







posted on   海岛Blog  阅读(192)  评论(0编辑  收藏  举报

编辑推荐:
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
阅读排行:
· 10年+ .NET Coder 心语 ── 封装的思维:从隐藏、稳定开始理解其本质意义
· 地球OL攻略 —— 某应届生求职总结
· 提示词工程——AI应用必不可少的技术
· Open-Sora 2.0 重磅开源!
· 周边上新:园子的第一款马克杯温暖上架

导航

< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5
点击右上角即可分享
微信分享提示