HUST 1010 The Minimum Length (KMP 最短循环节)

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde

Sample Output

3
7
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=1000010;
char t[maxn];
int n[maxn];
int len;
void get_next()
{
    int i=0;
    int j=-1;
    n[0]=-1;
    while(i<len)
    {
        if(j==-1||t[i]==t[j])
        {
            i++;
            j++;
            n[i]=j;
        }
        else
            j=n[j];
    }
}
int main()
{
    while(scanf("%s",t)!=EOF)
    {
        int j,i;
        len=strlen(t);
        memset(n,0,sizeof(n));
        get_next();
       printf("%d\n",len-n[len]);
    }
    return 0;
}

 

posted on 2015-07-22 11:32  甜蜜蜜吖甜蜜蜜  阅读(184)  评论(1编辑  收藏  举报

导航