动态规划习题 poj1050

原题:
To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 31305   Accepted: 16272

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

解题思路:dp

代码如下:

#include<iostream>
#include<cstring>
using namespace std;

int num;
int states[100][100];
int input[100];
int main()
{
    int max = -127;
    cin>>num;
    memset(states, 0, sizeof(states));
    for(int n=0; n<num; n++)
    {
        for(int x=0; x<num; x++)
            cin>>input[x];
        for(int i=0; i<num; i++)
        {
            int sum = 0;
            for(int j=i; j<num; j++)
            {
                sum += input[j];
                states[i][j] = states[i][j]+sum > sum ? states[i][j]+sum : sum;
                max = max >= states[i][j] ? max : states[i][j];
            }
        }
    }
    cout<<max<<endl;
    return 0;
}

 

 
posted @ 2012-05-19 13:41  王耀it  阅读(214)  评论(0编辑  收藏  举报