POJ 3279 Fliptile

POJ 3279 Fliptile

题目链接http://poj.org/problem?id=3279

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:

给你一个m*n的矩阵。每块有两种状态0/1。已知任意翻转期中一块,其上下左右四块都翻转。问能否将其全部翻转为0.如果可以,最小需要翻转多少次?

题解:

首先第一行可以用二进制枚举所有的翻转情况1表示翻转,0表示不翻转。由于第一行确定。后面的翻转条件就是它上一块为1这样只需判断翻转后最后一行是否全为0即可。(由于自己犯二,在第一行翻转的时候忘记翻转当前块的下一块,导致错了好多次找不出来原因)

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
int m,n;
bool rec[40][40];
bool cp[40][40];
bool step[40][40];
bool ans[40][40];
int solve(int line)
{
	int c = 0;
	for (int i = 1;i <= m;i++)
		for (int j = 1;j <= n;j++)
			cp[i][j] = rec[i][j];
	for (int j = 1;j <= n;j++){
		if (line%2){
			c++;
			step[1][j] = 1;
			cp[1][j] ^= 1;
			cp[1][j-1] ^= 1;
			cp[1][j+1] ^= 1;
			cp[2][j] ^= 1;
		}
		line /= 2;
	}
	for (int i = 2;i <= m;i++){
		for (int j = 1;j <= n;j++){
			if (cp[i-1][j] == 1){
				c++;
				step[i][j] = 1;
				cp[i][j] ^= 1;
				cp[i-1][j] ^= 1;
				cp[i+1][j] ^= 1;
				cp[i][j-1] ^= 1;
				cp[i][j+1] ^= 1;
			}
		}
	}
	for (int j = 1;j <= n;j++)
		if (cp[m][j])
			return -1;
	return c;
}
int main(int argc, char const *argv[])
{
	while (~scanf("%d %d",&m,&n)){
		for (int i = 1;i <= m;i++)
			for (int j = 1;j <= n;j++)
				cin>>rec[i][j];
		int mi = 0x3f3f3f3f;
		for (int line = 0;line < (1 << n);line++){
			memset(step,0,sizeof(step));
			int temp = solve(line);
			if (temp < mi && temp != -1){
				mi = temp;
				for (int i = 1;i <= m;i++)
					for (int j = 1;j <= n;j++)
						ans[i][j] = step[i][j];
			}
		}
		if (mi == 0x3f3f3f3f)
			printf("IMPOSSIBLE\n");
		else {
			for (int i = 1;i <= m;i++){
				for (int j = 1;j <= n;j++){
					if (j != 1)
						cout<<" ";
			    	cout<<ans[i][j];
				}
				cout<<endl;
			}
		}
	}
	return 0;
}
posted @ 2016-05-20 13:50  Thecoollight  阅读(207)  评论(0编辑  收藏  举报