In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
 
#include <stdio.h> 
#include <algorithm>
#include <set>
#include <vector>
#include <string>
#include <iostream>
#include <queue>
using namespace std;
const int maxn=2001;
int a[maxn] ;
int n,m;
vector<int> v;
void dfs(int index){
    v.push_back(a[index]);
    if(index*2>n){
        if(index<=n){
            for(int i=0;i<v.size();i++){
                printf("%d%s",v[i],i!=v.size()-1?" ":"\n");
            }
        }
    }
    else{
        //v.push_back(a[index*2+1]);
        dfs(index*2+1);
        //v.pop_back();
        //v.push_back(a[index*2]);
        dfs(index*2);
        //v.pop_back();
    }
    v.pop_back();
}
void postorder(int root){
    if(root<=n){
        postorder(2*root);
        postorder(2*root+1);
        printf("%d%s",a[root],root==1?"\n":" ");
    }
}
int main(){
    scanf("%d %d",&m,&n);
    for(int j=0;j<m;j++){
        int ismax=1,ismin=1;
        for(int i=1;i<=n;i++){        
            scanf("%d",&a[i]);        
        }
        for(int i=2;i<=n;i++){
            if(a[i/2]>a[i])ismin=0;
            if(a[i/2]<a[i])ismax=0;
        }
        if(ismin==1)printf("Min Heap\n");
        else{
            printf("%s\n",ismax==1?"Max Heap":"Not Heap");
        }
        postorder(1);
    }

}

注意点:这题和1155 Heap Path 差不多,就是输出变成了后序遍历。