TZOJ 1545 Hurdles of 110m(01背包dp)

描述

In the year 2008, the 29th Olympic Games will be held in Beijing. This will signify the prosperity of China and Beijing Olympics is to be a festival for people all over the world as well.

Liu Xiang is one of the famous Olympic athletes in China. In 2002 Liu broke Renaldo Nehemiah's 24-year-old world junior record for the 110m hurdles. At the 2004 Athens Olympics Games, he won the gold medal in the end. Although he was not considered as a favorite for the gold, in the final, Liu's technique was nearly perfect as he barely touched the sixth hurdle and cleared all of the others cleanly. He powered to a victory of almost three meters. In doing so, he tied the 11-year-old world record of 12.91 seconds. Liu was the first Chinese man to win an Olympic gold medal in track and field. Only 21 years old at the time of his victory, Liu vowed to defend his title when the Olympics come to Beijing in 2008.

In the 110m hurdle competition, the track was divided into N parts by the hurdle. In each part, the player has to run in the same speed; otherwise he may hit the hurdle. In fact, there are 3 modes to choose in each part for an athlete -- Fast Mode, Normal Mode and Slow Mode. Fast Mode costs the player T1 time to pass the part. However, he cannot always use this mode in all parts, because he needs to consume F1 force at the same time. If he doesn't have enough force, he cannot run in the part at the Fast Mode. Normal Mode costs the player T2 time for the part. And at this mode, the player's force will remain unchanged. Slow Mode costs the player T3 time to pass the part. Meanwhile, the player will earn F2 force as compensation. The maximal force of a player is M. If he already has M force, he cannot earn any more force. At the beginning of the competition, the player has the maximal force.

The input of this problem is detail data for Liu Xiang. Your task is to help him to choose proper mode in each part to finish the competition in the shortest time.

输入

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

Each test case begins with two positive integers N and M. And following N lines denote the data for the N parts. Each line has five positive integers T1 T2 T3 F1 F2. All the integers in this problem are less than or equal to 110.

输出

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the shortest time that Liu Xiang can finish the competition.

样例输入

2
1 10
1 2 3 10 10
4 10
1 2 3 10 10
1 10 10 10 10
1 1 2 10 10
1 10 10 10 10 

样例输出

1
6

提示

For the second sample test case, Liu Xiang should run with the sequence of Normal Mode, Fast Mode, Slow Mode and Fast Mode.

题意

有N个障碍需要跨过去,跨过障碍有3种方式:快跑T1秒,消耗F1能量;普通跑T2秒,消耗0;慢跑T3秒,获得F2能量,求跨过N个障碍需要最短的时间

题解

算是一道简单的01背包问题,Dp[i][j],i为第i个障碍,j为剩余能量

  快跑:Dp[i][j-f1[i]]=min(Dp[i][j],Dp[i-1][j-f1[i]]+t1[i]);

  普通:Dp[i][j]=min(Dp[i][j],Dp[i-1][j]+t2[i]);

  慢跑:如果j+f2[i]<=m时,

      Dp[i][j+f2[i]]=min(Dp[i][j],Dp[i-1][j+f2[i]]+t3[i]);

     如果j+f2[i]>m时,这里获得能量不能超过m,多出来的能量浪费(艰难的错了WA了几次,英语渣了)

      Dp[i][m]=min(Dp[i][m],Dp[i-1][j]+t3[i]);

代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int main()
{
    int t,n,m;
    scanf("%d",&t);
    int Dp[100][100];
    int t1[100],t2[100],t3[100],f1[100],f2[100];
    while(t--)
    {
        memset(Dp,INF,sizeof(Dp));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d%d%d%d%d",&t1[i],&t2[i],&t3[i],&f1[i],&f2[i]);
        for(int j=0;j<=m;j++)
            Dp[0][j]=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=m;j++)
            {
                //normal
                Dp[i][j]=min(Dp[i][j],Dp[i-1][j]+t2[i]);
                //fast
                if(j-f1[i]>=0)
                    Dp[i][j-f1[i]]=min(Dp[i][j-f1[i]],Dp[i-1][j]+t1[i]);
                //slow
                if(j+f2[i]<=m)//不过载
                    Dp[i][j+f2[i]]=min(Dp[i][j+f2[i]],Dp[i-1][j]+t3[i]);
                else//能量过载
                    Dp[i][m]=min(Dp[i][m],Dp[i-1][j]+t3[i]);
            }
        }
        int minn=INF;
        for(int j=0;j<=m;j++)
            minn=min(minn,Dp[n][j]);
        printf("%d\n",minn);
    }
    return 0;
}

posted on 2018-02-13 23:34  大桃桃  阅读(328)  评论(0编辑  收藏  举报

导航