杭电1867 A + B for you again

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3811    Accepted Submission(s): 970


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
asdf sdfg asdf ghjk
 

Sample Output
asdfg asdfghjk
 
#include<stdio.h>
#include<string.h>
const int n=100001;
int next[n];
int len1,len2;
void getnext(char s[])
{
int i=0,j=-1;
next[0]=-1;
while(i<=len2)
{
if(j==-1||s[i]==s[j])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
}
}
int kmp(char s1[],char s2[])
{
int i=0,j=0;
len1=strlen(s1);
len2=strlen(s2);
getnext(s2);
    while(i<len1&&j<len2)
    {
if(j==-1||s1[i]==s2[j])
{
i++;
j++;
}
else
j=next[j];
}
if(i>=len1)
return j;
else
return 0;
}
int main()
{
char str1[n],str2[n];
while(~scanf("%s%s",str1,str2))                    
 /*这一题不用str1+1会更加方便,上一题剪布条的其实也可以直接用s而不用s+1,只要把getnext()和kmp()里面的一些值改一下就可以  */
{
int a=kmp(str1,str2);
int b=kmp(str2,str1);
if(a==b)
{
if(strcmp(str1,str2)>0)
{
printf("%s",str2);
printf("%s\n",str1+a);
}
else
{
printf("%s",str1);
printf("%s\n",str2+a);
}
}
else if(a>b)
{
printf("%s",str1);
printf("%s\n",str2+a);
}
else
{
printf("%s",str2);
printf("%s\n",str1+b);
}
}
}
posted @ 2014-05-19 19:46  awenzero  阅读(78)  评论(0编辑  收藏  举报