hdu1102 constructing road

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13106    Accepted Submission(s): 4954


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 
不知道什么情况,k从1开始时错了,改为0却正确了,到底什么情况。。。。
#include<stdio.h>
#include<stdlib.h>
struct node
{
int x;
int y;
int cost;
}b[10000];
int k,fa[101];
int cmp(const void *aa,const void *bb)
{
node *a=(node *)aa;
node *b=(node *)bb;
return a->cost-b->cost;
}
int find(int x)
{
if(fa[x]!=x)
fa[x]=find(fa[x]);
return fa[x];
}
int kruskal()
{
int acost=0;
qsort(b,k,sizeof(b[0]),cmp);
for(int i=0;i<k;i++)
{
int ka=find(b[i].x);
int kb=find(b[i].y);
if(ka!=kb)
{
fa[ka]=kb;
acost+=b[i].cost;
}
}
return acost;
}

int main()
{
int i,j,ans,n,a[101][101],q,d,e;
while(~scanf("%d",&n))
{
k=0;
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
scanf("%d",&a[i][j]);
for(i=1;i<n;i++)
for(j=i+1;j<=n;j++)
{
 
b[k].x=i;
b[k].y=j;
b[k].cost=a[i][j];
k++;
}
scanf("%d",&q);
for(i=0;i<q;i++)
{
scanf("%d%d",&d,&e);            //看别人代码居然要把d和e从小到大排序,感觉没必要。。。
for(j=0;j<k;j++)
    if(b[j].x==d&&b[j].y==e)
    b[j].cost=0;
}
for(i=1;i<=n;i++)               //对kruskal还是不够熟悉,刚开始居然忘了这一步
fa[i]=i;
ans=kruskal();
printf("%d\n",ans);
}
}
posted @ 2015-05-06 18:33  awenzero  阅读(143)  评论(0编辑  收藏  举报