An easy problem

An easy problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2563    Accepted Submission(s): 1806


Problem Description

In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.
 

Input

The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
 

Output

For each test case, print out the multiply table.
 

Sample Input
2
1
4
 

Sample Output
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16

#include <stdio.h>
int main( )
{
int N, T;
scanf(
"%d", &T);
while(T--) {
scanf(
"%d", &N);
int i, j, flag = 0;
for(i = 1; i <= N; i++) {
for(j = 1; j <= N; j++) {
if (!flag)
printf(
"%d",i * j), flag = 1;
else
printf(
" %d",i *j);
}
flag
= 0;
puts(
"");
}
}
return 0;
}

Hint

posted on 2011-08-16 22:59  more think, more gains  阅读(174)  评论(0编辑  收藏  举报

导航