hdu 1087Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7997    Accepted Submission(s): 3210


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
4 10 3
 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main( )
{
 int N;
 while(scanf("%d",&N)!=EOF,N)
 {
   int i,j,t,A[10000],sum[10000];
   memset(A,0,sizeof(A));
   memset(sum,0,sizeof(sum));
   for(i=1;i<=N;i++)
   scanf("%d",&A[i]);
   for(i=1;i<=N;i++)
   sum[i]=A[i];
   int flag=0;
   for(i=2;i<=N;i++)
{
         for(j=i-1;j>=1;j--)
            {
        if(A[j]<A[i]&&!flag)
                 {
                  sum[i]+=sum[j];
                  t=sum[i];
                  flag=1;
                  }
            else if(A[j]<A[i])
                { 
                    t=sum[j]+A[i];
                       if (sum[i]<t)
                          sum[i]=t;
                 }    
               }
     flag=0;
}
      int res=sum[1];
    for(i=2;i<=N;i++)
    {
        if(sum[i]>res)
          res=sum[i];
    }
      printf("%d\n",res);
    }
  return 0;
}
也是简单dp,在老大提示思路后,做出来的。。开始提交时wrong answer ..因为没有考虑到这种情况。。7 6 4 5 7
回过头来才发现,这道题,竟然是被我模拟题意而水过的,哈哈,太没技术含量了,这道题是找给定序列的最大递增序列和,真正的好的做法也是找其状态转移方程:
sum[i]=max{sum[j]}+a[i];
求出每一次sum[i],找出最大的和就可以了..
   
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int A[1010],sum[1010];
int main( )
{
  int N;
  while(scanf("%d",&N)!=EOF,N)
  {
   memset(sum,0,sizeof(sum));
   int i,j,k,n=-1000,t;
   for(i=0;i<N;i++)
   scanf("%d",A+i);
   sum[0]=A[0];
   for(i=1;i<N;i++)
   {
     t=0;
     for(j=0;j<i;j++)
     if(A[j]<A[i]&&t<sum[j])
     t=sum[j];
     sum[i]=t+A[i];
    if(sum[i]>n)
     n=sum[i];
  }
  printf("%d\n",n);
}
return 0;
}
   
   
   

posted on 2011-04-17 23:17  more think, more gains  阅读(143)  评论(0编辑  收藏  举报

导航