PAT Basic 1042. 字符统计

PAT Basic 1042. 字符统计

1. 题目描述:

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

2. 输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

3. 输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

4. 输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

5. 输出样例:

e 7

6. 性能要求:

Code Size Limit
16 KB
Time Limit
400 ms
Memory Limit
64 MB

思路:

除草题,考察基础IO,一开始以为要统计ASCII码表中所有可见字符。。。

这里还需要注意的是因为输入中含有空格,scanf()无法读入正确的输入,这里我改为fgets()读入。

My Code:

#include <stdio.h>
#include <ctype.h> // tolower header

#define MAX_LEN 1000

int main(void)
{
    char words[MAX_LEN+1] = "";
    int count[26] = {0}; // count lowercase
    char *pChar = NULL;
    int maxIndex = 0;
    int i=0;
    
    //scanf("%s", words);
    fgets(words, MAX_LEN+1, stdin); // first submit get error, cause scanf can't get correct input
    
    pChar = words;
    
    while(*pChar)
    {
        if(tolower(*pChar) >= 'a' && tolower(*pChar) <= 'z')
        {
            count[tolower(*pChar) - 'a']++;
        }
        pChar++;
    }
    
    for(i=1; i<26; i++)
    {
        if(count[i]>count[maxIndex])
            maxIndex = i;
    }
    
    printf("%c %d\n", maxIndex+'a', count[maxIndex]);
    
    return 0;
}
posted @ 2023-03-20 20:22  十豆加日月  阅读(10)  评论(0编辑  收藏  举报